Skip to Questions

Ask A Librarian!

Q

Is Respondus LockDown Browser compatible with Internet Explorer 8?

Last Updated: Apr 26, 2013  |  9 Views

Was this helpful? 0   0
A

Answer

There were issues with a early versions of Internet Explorer 8, which caused problems Respondus LockDown Browser. These issues have been addressed by Microsoft in the latest IE8 update, so if you are encountering LockDown Browser issues with IE8 please upgrade to the latest version of IE8 or upgrade to the latest version of Internet Explorer, currently IE9.

Answered by Jessica ManzoBookmark and Share

Other Answers / Comments (0)

    More ways to ask us!

    • a small icon
      Via SMS: TXT your question to (601)326-2031  more info
    • a small icon
      Call us (601) 925-3916
    • a small icon
    • a small icon
      Ask in person on library 2nd floor at Reference Desk